summaryrefslogtreecommitdiff
path: root/app-text/cedilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /app-text/cedilla
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'app-text/cedilla')
-rw-r--r--app-text/cedilla/Manifest2
-rw-r--r--app-text/cedilla/cedilla-0.7.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-text/cedilla/Manifest b/app-text/cedilla/Manifest
index 1ae2d82809fc..51db8cde98a5 100644
--- a/app-text/cedilla/Manifest
+++ b/app-text/cedilla/Manifest
@@ -1,4 +1,6 @@
AUX cedilla-gentoo-r1.patch 645 BLAKE2B cedc4626df03c6706c5fee463cd2b662f1b5e297050cb3e67e585609319daa013d499f37fd6cff1ce2a10fcb21626e6b5178dc5545a02eef0778c404cd00f9fb SHA512 4a9d4c4f28509e2b527568a28a69dbcce0c4e7a8d6ae9a967dfb33ff639f12a5dae16a885b0f51686d3d444c9f651cf904bb5c93326308fc37e13d4ec8bb4162
DIST cedilla-0.6.tar.gz 130676 BLAKE2B e316dff5ab9bb89dd350e9842847ed700846cfd57370be17198aa3c54f0562a4c26d23a49acccf8c7dc0b55f1765668dbfa24dbf57f50e568ac3039f7b5d662c SHA512 95d98fd4ab95b48023f635d61133ea1a8138a797cd1c414da0d4907531eb067ac147e8d612a528373da425d37fee7c1139dc7f0019308938c096e37caebf4e38
+DIST cedilla-0.7.tar.gz 114899 BLAKE2B 100c22be30ffed585a1eb44c96109dadab9cbf90c5c3432efd4ed8daa135fa0d9fb82374eda9f9f13126cc5d453ecb5933d8733a58e374ab3192ea7d5bd6d273 SHA512 a137bceee2c70e911922b17e823093dc37b19cce8dece99596003ae7b4bc8c02afbae164d7dfa4e4873b4f549f7d948faf1da9dc1d3ef89cde6d1f36ba91be77
EBUILD cedilla-0.6.ebuild 697 BLAKE2B c1f1bcb2967e8c6068d3b6906dee9ca5279360689e4aa80836d72aeca426db5d94631ee8f541acd3b71c89084965e87919b9e2a64a7ed837ddcb93c25e9c2e04 SHA512 61c7d132115f2e255de5b1aad34397541f89fdaa1ebd24dab36e7b2d71bac7e592884a78d36bc3addd8108133091455bd0025c28c672787f0a995b0bba919fae
+EBUILD cedilla-0.7.ebuild 654 BLAKE2B b784971be122031e96b156d0cf2d2b6930bb97236101a931b92094c0860e817618654fbc42ca3828222daa1208065722b62ba1b60d13c13c7ec163f9b2d4f92f SHA512 66dc5955c4b7391b91fa8f0cf521b5f1a7b8962c2ba8ded1c379dc678ed197db3217bf661da9cfa55569161acf45f70af95955d44e092d703237bf7afb01ade3
MISC metadata.xml 253 BLAKE2B 34807135fdbc8396660d3fa85339e80c0c14693b937e360de963062b40d1a4306d86c3f6fbe60c45146632f934695d26c06083a2977031c36bdee17f57140f72 SHA512 06255a02d9a177532c33fb7a9271f8f538cef82354feb7689c839e2eb1516d53fd0e78aca22fee2f9a19dbf1e3f7ad96dea23c8d97efdac952e4b754314664d9
diff --git a/app-text/cedilla/cedilla-0.7.ebuild b/app-text/cedilla/cedilla-0.7.ebuild
new file mode 100644
index 000000000000..d6e687479ec5
--- /dev/null
+++ b/app-text/cedilla/cedilla-0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="UTF-8 to postscript converter"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="dev-lisp/clisp"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cedilla-gentoo-r1.patch )
+
+src_compile() {
+ ./compile-cedilla || die "Compile failed."
+}
+
+src_install() {
+ sed "s#${ED%/}##g" -i cedilla || die "sed failed"
+ dodir /usr/share/man/man1/
+
+ ./install-cedilla || die "Install failed."
+
+ einstalldocs
+}