summaryrefslogtreecommitdiff
path: root/app-text/cedilla/cedilla-0.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /app-text/cedilla/cedilla-0.7-r1.ebuild
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'app-text/cedilla/cedilla-0.7-r1.ebuild')
-rw-r--r--app-text/cedilla/cedilla-0.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/cedilla/cedilla-0.7-r1.ebuild b/app-text/cedilla/cedilla-0.7-r1.ebuild
new file mode 100644
index 000000000000..ba9a1e203dc8
--- /dev/null
+++ b/app-text/cedilla/cedilla-0.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="UTF-8 to postscript converter"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/
+ https://github.com/jech/cedilla"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lisp/clisp"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cedilla-gentoo-r1.patch )
+
+src_compile() {
+ ./compile-cedilla || die "Compile failed."
+}
+
+src_install() {
+ sed "s#${ED}##g" -i cedilla || die "sed failed"
+ dodir /usr/share/man/man1/
+
+ ./install-cedilla || die "Install failed."
+
+ einstalldocs
+}