summaryrefslogtreecommitdiff
path: root/app-text/c2ps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/c2ps
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/c2ps')
-rw-r--r--app-text/c2ps/Manifest4
-rw-r--r--app-text/c2ps/c2ps-4.0.ebuild26
-rw-r--r--app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch11
-rw-r--r--app-text/c2ps/metadata.xml8
4 files changed, 49 insertions, 0 deletions
diff --git a/app-text/c2ps/Manifest b/app-text/c2ps/Manifest
new file mode 100644
index 000000000000..15ced37b9ffe
--- /dev/null
+++ b/app-text/c2ps/Manifest
@@ -0,0 +1,4 @@
+AUX c2ps-4.0-LDFLAGS.patch 342 BLAKE2B 7f6b97c231d9180007daa7982b8caeb98989bdce8efbac983cd3b5333e68ca366a2cd9521e66ea54e9e2af6d0ca91af01a1bf2f6c4e56e257baf275b37d6fdcd SHA512 79e943df0b2edbb6a7ab915e4760c46d34ac281eb2249f24be26ead327cf0f2bdf1aea58cf9e76453e89b2902ec2790eb50210cfcb433ab91a8449b03fcc3945
+DIST c2ps-4.0.tar.gz 48137 BLAKE2B b2d07f97e1eee0d7e32070d828ec2c06d9d98fd6a480768e6580f8a12bf0974983ed144a6e92a9860f13e6b9ec780f9aa1a28ee42cedaa70c7d4ab6ca5e6eca9 SHA512 dde931a201950412c8aad04a59f9ca0862b21a221bb7212ee64cbba0193421f1538804525361075be3ed601c5015a0c4e0c3592696f8b545f5a45524b2c5c619
+EBUILD c2ps-4.0.ebuild 683 BLAKE2B d0681ebb59b6b65c7eb20c942f26733eedd52d94ae541bc9a5cd63f8e6dc1b67953e7a6283b528c6e87e29fc1177dc8025dde8cc08c3bee995fd6e3916cf2ce6 SHA512 a101fe636fef9abaacc97f96e225b99965462fbdf1744ef113a4abcee43bf351a5195d881b1537f97d4995b5017bb9ca112ecf808a6d6c054a711daf52d66111
+MISC metadata.xml 255 BLAKE2B 06f078acf8e4416705c8bad8b4802a44592eb962c08c050e11332bfa97564fafdf08754ab056eb813f6baeaa6cdfaf5d71672455d77e74045f86098c221d5136 SHA512 c6c5f966cfbe396fde1b15334442de9e0004b44c4b48775588b0b25a058ad1751252761370c9c254280e97561fa6306f5aa0cc7959c675d4ee11f7f95d777a36
diff --git a/app-text/c2ps/c2ps-4.0.ebuild b/app-text/c2ps/c2ps-4.0.ebuild
new file mode 100644
index 000000000000..667ebb401a85
--- /dev/null
+++ b/app-text/c2ps/c2ps-4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit base toolchain-funcs
+
+DESCRIPTION="Generates a beautified ps document from a source file (c/c++)"
+HOMEPAGE="http://www.cs.technion.ac.il/users/c2ps"
+SRC_URI="http://www.cs.technion.ac.il/users/c2ps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-LDFLAGS.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ emake MAN="${ED}"/usr/share/man/man1 PREFIX="${ED}"/usr install
+ dodoc README
+}
diff --git a/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch b/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch
new file mode 100644
index 000000000000..d68002180091
--- /dev/null
+++ b/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/c2ps-4.0/Makefile 1997-05-15 11:50:56.000000000 -0400
++++ b/c2ps-4.0/Makefile 2010-09-24 19:42:33.000000000 -0400
+@@ -45,7 +45,7 @@
+ install -m 644 c2ps.1 $(MAN)
+
+ compile: c2ps.c
+- $(CC) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c
++ $(CC) $(LDFLAGS) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c $(LIBS)
+
+ clean:
+ $(RM) c2ps *.o core *~
diff --git a/app-text/c2ps/metadata.xml b/app-text/c2ps/metadata.xml
new file mode 100644
index 000000000000..c439b06d8c84
--- /dev/null
+++ b/app-text/c2ps/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>printing@gentoo.org</email>
+ <name>Gentoo Printing Project</name>
+</maintainer>
+</pkgmetadata>