summaryrefslogtreecommitdiff
path: root/app-text/c2ps/c2ps-4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/c2ps/c2ps-4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/c2ps/c2ps-4.0.ebuild')
-rw-r--r--app-text/c2ps/c2ps-4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/c2ps/c2ps-4.0.ebuild b/app-text/c2ps/c2ps-4.0.ebuild
new file mode 100644
index 000000000000..667ebb401a85
--- /dev/null
+++ b/app-text/c2ps/c2ps-4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit base toolchain-funcs
+
+DESCRIPTION="Generates a beautified ps document from a source file (c/c++)"
+HOMEPAGE="http://www.cs.technion.ac.il/users/c2ps"
+SRC_URI="http://www.cs.technion.ac.il/users/c2ps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-LDFLAGS.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ emake MAN="${ED}"/usr/share/man/man1 PREFIX="${ED}"/usr install
+ dodoc README
+}