summaryrefslogtreecommitdiff
path: root/app-text/bogosort/bogosort-0.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/bogosort/bogosort-0.4.2-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/bogosort/bogosort-0.4.2-r1.ebuild')
-rw-r--r--app-text/bogosort/bogosort-0.4.2-r1.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/app-text/bogosort/bogosort-0.4.2-r1.ebuild b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
index c8b07c12cae0..a8a12ad1ae77 100644
--- a/app-text/bogosort/bogosort-0.4.2-r1.ebuild
+++ b/app-text/bogosort/bogosort-0.4.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="A file sorting program which uses the bogosort algorithm"
HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"
@@ -12,15 +12,23 @@ SRC_URI="ftp://ulrik.haugen.se/pub/unix/bogosort/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ~mips ppc sparc x86 ~x86-linux ~ppc-macos"
-IUSE=""
-DEPEND=""
-RDEPEND=""
+PATCHES=(
+ "${FILESDIR}"/xmalloc.patch
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${PN}-0.4.2-implicit-decl.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/xmalloc.patch \
- "${FILESDIR}"/${P}-glibc-2.10.patch
+ default
+
+ mv configure.{in,ac} || die
+
+ sed -i \
+ -e 's:-O0::' \
+ -e '/maintainer-targets/d' \
+ Makefile.am || die
+ eautoreconf
}
src_configure() {