summaryrefslogtreecommitdiff
path: root/app-text/asciidoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-text/asciidoc
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest2
-rw-r--r--app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index 90b47eb07a80..56f8fd59b409 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,3 +1,5 @@
DIST asciidoc-8.6.10_p20181016.tar.gz 576694 BLAKE2B 4d255606675346d00ab03398bf48cb30d357f9f9366944e4faf66ae4c96dafce49acdd930fc848f3dbb2d704a004bb5815d17b53416a76c8368a92e4716328b2 SHA512 801f360b0c444e932f1c50897d446de0ec3f0fb2206080b5aa6dda396fede96065f7bb629a84c8a8e40c5d8897f305fdb1877512f04ae757f3b142fd3a7305d0
+DIST asciidoc-9.0.0_rc1.tar.gz 1143528 BLAKE2B 97e2ee77cf7554e2e0d53e792213377e6cb233853717487b0c0ac1c70d233a5d58a08f3aa69ae840c90f98185b595f9feb7396795b2de47ff0cfc0147920bc2a SHA512 965d65df18ff90596e5cd72bec8d0f7daf2f6ad585ec77af2a6ae9637569b613e2384cc7015c1823fcde99be8170107789505a543fe8b6d3273f2c75a6a92960
EBUILD asciidoc-8.6.10_p20181016-r1.ebuild 2620 BLAKE2B 4ae19fa2b8362818e9b5a04226aa7c4b57dd027efab22b0c9881ee3c3ce0d6b4d5ed903f03e0a26962d93ccdb125d73b1ef9e0a22178fb54fe28ef186b42ae2e SHA512 b01efd0d8d1b03de83bd39b37fee70645812795dba6136ea0410258793f4775e41a7ec9392e4b572dfb2db6bd76582de0a605704bb0dc026025044f5e971fdf6
+EBUILD asciidoc-9.0.0_rc1.ebuild 2727 BLAKE2B 09cf677eff56b5a84cb62b36ce2baae2a132806f1fc860546058a33d49bc6d8123668d92b348fed330c33e265113056e2aa71ada291db03e0bd484f8375115f6 SHA512 6acaa452918764b6151ea17284e4b528c88a89bfc3f58796ab5e4dd81d80f39fd3eae364bd1353ae2b39a21945e13732e64019e20674a962d7c3b8b39d489298
MISC metadata.xml 514 BLAKE2B 89fefee3e8081fc45a8251255bf365f58eba6aa9eef92a23bd8f234703b7062b1dd2a415260fcda1b799cffa4b46d0da22b153ba8de6b77cb6076666ff43ccb7 SHA512 2587ac6d8c24ceca295eef2dc6e0735461dd09864d6a1f282d67fc3c58cd18aa565099a2c280edec143024295b74a251152918932c37d3be450aef68d367ca70
diff --git a/app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild b/app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild
new file mode 100644
index 000000000000..1b8ec0e44bfd
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9.0.0_rc1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
+
+inherit autotools eutils python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="http://asciidoc.org/ https://github.com/asciidoc/asciidoc-py3/"
+SRC_URI="https://github.com/${PN}/${PN}-py3/archive/9.0.0rc1.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+ "
+DEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ app-text/dvipng
+ app-text/dvisvgm
+ dev-texlive/texlive-latex
+ dev-util/source-highlight
+ media-gfx/graphviz
+ media-gfx/imagemagick
+ media-sound/lilypond
+ )"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+DOCS=( BUGS.txt CHANGELOG.txt README.asciidoc
+ docbook-xsl/asciidoc-docbook-xsl.txt dblatex/dblatex-readme.txt
+ filters/code/code-filter-readme.txt )
+
+S="${WORKDIR}/${PN}-py3-9.0.0rc1"
+
+src_prepare() {
+ default
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_test() {
+ local -x ASCIIDOC_PY=asciidoc.py
+ "${EPYTHON}" tests/test${PN}.py run || die
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED}"/usr/bin/*.py
+
+ readme.gentoo_create_doc
+
+ # Below results in some files being installed twice in different locations, but they are
+ # in the right place, uncompressed, and there won't be any broken links. See bug #483336
+ if use examples; then
+ # examples/website is full of relative symlinks,
+ # deref them for copying, which dodoc doesn't do
+ cp -rL examples/website "${ED}"/usr/share/doc/${PF}/examples || die
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "\"music\" filter support" "media-sound/lilypond media-gfx/imagemagick"
+ optfeature "\"source\" filter support" dev-util/source-highlight dev-python/pygments app-text/highlight
+ optfeature "\"latex\" filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "\"graphviz\" filter support" media-gfx/graphviz
+}