summaryrefslogtreecommitdiff
path: root/app-text/antixls/antixls-0.3b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
commit8fcdcec5fbdd0e3a77391e4f354218014f59f358 (patch)
treeb6aaf9c103052f2ab4a948377142f4a4233caa60 /app-text/antixls/antixls-0.3b.ebuild
parent423d21dcfee183cc4b04d29c1621615e8c30f834 (diff)
gentoo resync : 05.01.2018
Diffstat (limited to 'app-text/antixls/antixls-0.3b.ebuild')
-rw-r--r--app-text/antixls/antixls-0.3b.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/app-text/antixls/antixls-0.3b.ebuild b/app-text/antixls/antixls-0.3b.ebuild
index 14a98632b593..53e29234db59 100644
--- a/app-text/antixls/antixls-0.3b.ebuild
+++ b/app-text/antixls/antixls-0.3b.ebuild
@@ -1,16 +1,23 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
DESCRIPTION="Print out an XLS file with minimal formatting, or extract the data into CSV"
-HOMEPAGE="http://www.af0.net/~dan/?antixls"
-SRC_URI="http://www.af0.net/~dan/repos/${P}.perl"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.perl"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND="dev-perl/Spreadsheet-ParseExcel"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}/${P}.perl" "${S}"/${PN} || die
+}
src_install() {
- mv "${DISTDIR}/${P}.perl" ${PN}
dobin ${PN}
}