summaryrefslogtreecommitdiff
path: root/app-text/ansifilter/ansifilter-2.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 17:36:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 17:36:29 +0000
commit0485fd7e57de60b61c04825f986bb3400bcf7116 (patch)
tree8bc2ab515d65bccf3fa878f133e82577074ee982 /app-text/ansifilter/ansifilter-2.19.ebuild
parent3a5772102e4f2b6f9cc46f461c90970060ae0c5e (diff)
gentoo auto-resync : 14:02:2024 - 17:36:28
Diffstat (limited to 'app-text/ansifilter/ansifilter-2.19.ebuild')
-rw-r--r--app-text/ansifilter/ansifilter-2.19.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-text/ansifilter/ansifilter-2.19.ebuild b/app-text/ansifilter/ansifilter-2.19.ebuild
deleted file mode 100644
index 0f7b29ac2fd8..000000000000
--- a/app-text/ansifilter/ansifilter-2.19.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs qmake-utils xdg
-
-DESCRIPTION="Handles text files containing ANSI terminal escape codes"
-HOMEPAGE="http://www.andre-simon.de/"
-SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-IUSE="gui"
-
-RDEPEND="
- gui? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- )
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog.adoc README.adoc )
-
-src_prepare() {
- default
-
- # bug 431452
- rm src/qt-gui/moc_mydialog.cpp || die
-
- sed \
- -e "/GZIP/d" \
- -e "/COPYING/d" \
- -i makefile || die
-
- sed \
- -e "s/-O2//" \
- -i src/makefile || die
-}
-
-src_configure() {
- if use gui ; then
- pushd src/qt-gui > /dev/null || die
- eqmake5
- popd > /dev/null || die
- fi
-}
-
-src_compile() {
- emake -f makefile CXX="$(tc-getCXX)"
-
- if use gui ; then
- emake -C src/qt-gui
- fi
-}
-
-src_install() {
- emake -f makefile \
- DESTDIR="${ED}" \
- doc_dir="/usr/share/doc/${PF}" \
- -j1 \
- install $(usev gui install-gui)
-
- einstalldocs
-}
-
-pkg_preinst() {
- use gui && xdg_pkg_preinst
-}
-
-pkg_postrm() {
- use gui && xdg_pkg_postrm
-}
-
-pkg_postinst() {
- use gui && xdg_pkg_postinst
-}