summaryrefslogtreecommitdiff
path: root/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/aiksaurus/aiksaurus-1.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/aiksaurus/aiksaurus-1.2.1.ebuild')
-rw-r--r--app-text/aiksaurus/aiksaurus-1.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/aiksaurus/aiksaurus-1.2.1.ebuild b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
new file mode 100644
index 000000000000..d359b259e030
--- /dev/null
+++ b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit flag-o-matic eutils libtool
+
+DESCRIPTION="A thesaurus lib, tool and database"
+HOMEPAGE="https://sourceforge.net/projects/aiksaurus"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="gtk"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch #214248
+
+ # Needed to make relink work on FreeBSD, without it won't install.
+ # Also needed for a sane .so versionning there.
+ elibtoolize
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+ econf $(use_with gtk)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README* ChangeLog
+}