summaryrefslogtreecommitdiff
path: root/app-text/agrep/agrep-2.04-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/agrep/agrep-2.04-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/agrep/agrep-2.04-r2.ebuild')
-rw-r--r--app-text/agrep/agrep-2.04-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/agrep/agrep-2.04-r2.ebuild b/app-text/agrep/agrep-2.04-r2.ebuild
new file mode 100644
index 000000000000..d2ff1e0dd621
--- /dev/null
+++ b/app-text/agrep/agrep-2.04-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/${PN}/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86 ~ppc-macos ~sparc-solaris"
+
+RDEPEND="
+ !dev-libs/tre
+ !dev-ruby/amatch
+ !app-misc/glimpse"
+
+DOCS=( README agrep.algorithms agrep.chronicle COPYRIGHT contribution.list )
+
+src_compile() {
+ sed -i \
+ -e 's/^CFLAGS.*//' \
+ -e "s:\$(CFLAGS):& \$(LDFLAGS) :" Makefile || die
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}