summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
commitd117dce29795dfc5a9824d31a128decaa37f73d2 (patch)
treeef95e8fa6dfdf9a769d594a457e755c8782a345b /app-shells
parentfa49bc1447d334c70e45ded349d3c37319dab7b4 (diff)
gentoo auto-resync : 25:02:2024 - 05:40:31
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin10311 -> 10305 bytes
-rw-r--r--app-shells/autojump/Manifest1
-rw-r--r--app-shells/autojump/autojump-22.5.3-r3.ebuild88
3 files changed, 89 insertions, 0 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index 4b1f5ca8521a..75e88390ed6c 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/autojump/Manifest b/app-shells/autojump/Manifest
index 038f0cdef795..0211c93e4e0b 100644
--- a/app-shells/autojump/Manifest
+++ b/app-shells/autojump/Manifest
@@ -1,4 +1,5 @@
AUX 22.5.3-Use-mock-from-unittest.patch 689 BLAKE2B b0d518d66efb7511b8bbd8d31f5ce00c7561e90e259289a4dff051665c19bc9f3537cb04ed77e89d18c9b3fd6edcb6e0b912f0b9dfc9db1fc491b11a21957828 SHA512 a15cf9369527535dd475db53aa014108af2fe6cc72b04b166589c2c9d7464dd2eb999998aa8d55fc306bd6432b3926dc11caf00009b7b45562221957dc748dcd
DIST autojump-22.5.3.tar.gz 55429 BLAKE2B 3a2773669f81d1a54c01cce9fe75bc01609265998b035b4ba1aa064f1132acf852b59eb04ebfa744e628152f0ab478cbef24e5aff326bf84cec6e2c9348e8360 SHA512 d1dd3cbb67fda4e0a17ec5028b947faf46be8a95a6cd8418127b927f42bc95b71538a06658b38b479c77d147a6cd5e8cef77639ef538c7d449414c469c13f140
EBUILD autojump-22.5.3-r2.ebuild 2041 BLAKE2B 688719cb1a5a8117bea31cffabf4967c496ce1c7b3ae3f24ce8f00bd3a1dfd1d25e9ba99941e20b4f3561874eceb8dfe5d1eaaefafd48f4b06c56f7ba417126a SHA512 2bbaf4197c13bbcd3134d1c93fb5d80fb23be48c1d4ac0b071e96f2992e67499fb3b62ed3397d9e0cf8e67a3abf9e508db467e737e4e51a6242337091fa74129
+EBUILD autojump-22.5.3-r3.ebuild 2043 BLAKE2B 8a6e07ea45440ae5d83bac3d8d08d9e643c5e96231b29daf06a2d71df1ecc450c3268ffd32b2672a49fc934d07146e86dd9edb2b1d902b96c890cd447614a9c1 SHA512 7e439de9fea620f397e51566ab336a1fa7144ccd69b53e6bd9d51c71d71329f6b7a8c26664286b5cea4c05efb3dfc7574152eb0d9315d69a7347a5efda0cc8e9
MISC metadata.xml 491 BLAKE2B 775beb745c9218ed955dca11149ccb5b17c3efacc8f916ca15a65f67632e01feac271d5a36c39316de8024f352427b658cf35e54f5d03682d681920b730af4bb SHA512 d26e3c132c90c94bae47c1f7a4af71eaf873a12546d429632736885c515764aa612fb8155003643678d2156b42e94a692b0e3174d2b4825b559426c29eaa863c
diff --git a/app-shells/autojump/autojump-22.5.3-r3.ebuild b/app-shells/autojump/autojump-22.5.3-r3.ebuild
new file mode 100644
index 000000000000..2d175c7c7050
--- /dev/null
+++ b/app-shells/autojump/autojump-22.5.3-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 vcs-snapshot prefix
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/wting/autojump"
+SRC_URI="https://github.com/wting/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="ipython test"
+REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+RDEPEND="ipython? ( ${PYTHON_DEPS} )"
+DEPEND="${PYTHON_DEPS}
+ test? (
+ >=dev-vcs/pre-commit-0.7.0[${PYTHON_SINGLE_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Use-mock-from-unittest.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s:/usr/local/share:/usr/share:" \
+ -i bin/autojump.sh || die
+
+ # autojump_argparse is only there for Python 2.6 compatibility
+ sed -e "s:autojump_argparse:argparse:" \
+ -i bin/autojump || die
+
+ hprefixify -q '"' -w '/usr\/share/' bin/autojump.sh
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/"${PN}"
+ python_doscript "${ED}"/usr/bin/"${PN}"
+
+ insinto /etc/profile.d
+ doins bin/"${PN}".sh
+
+ insinto /usr/share/"${PN}"/
+ doins bin/"${PN}.bash"
+ doins bin/"${PN}.zsh"
+ doins bin/"${PN}.fish"
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+
+ python_domodule bin/autojump_argparse.py bin/autojump_data.py \
+ bin/autojump_match.py bin/autojump_utils.py
+ if use ipython; then
+ python_domodule tools/autojump_ipython.py
+ fi
+
+ doman docs/"${PN}.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use ipython; then
+ elog 'This tool provides "j" for ipython, please add'
+ elog '"import autojump_ipython" to your ipy_user_conf.py.'
+ elog
+ fi
+
+ elog 'If you use app-shells/fish, add the following code to your'
+ elog 'config.fish to get autojump support:'
+ elog 'if test -f /usr/share/autojump/autojump.fish'
+ elog ' source /usr/share/autojump/autojump.fish'
+ elog 'end'
+}