summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-24 19:00:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-24 19:00:40 +0000
commita7689c2abcff4374b84d95fb2df980ec9a566965 (patch)
treec3a326274492772c07c074a813f1047d5d7f3d62 /app-shells
parentb1193c219a8c8da6e1e76cb5d394da129abbca41 (diff)
gentoo auto-resync : 24:03:2024 - 19:00:40
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin10628 -> 10626 bytes
-rw-r--r--app-shells/yash/Manifest2
-rw-r--r--app-shells/yash/yash-2.56.1.ebuild35
3 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index fa22c8392894..6ca230132e1b 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 60b321b21cf7..892160f00c7f 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,3 +1,5 @@
DIST yash-2.55.tar.xz 761184 BLAKE2B a6a73a4055766f310724bd78670870eb96be9c34f79c177a80d86876512adfdd9d67bb28fadd113cd230db5a7eaaa91a1926d1b942297ca735e7390460b7a8c0 SHA512 9e92fc86884b0b315a98fcb5da0f319f431515185a970762946b919ccccc72aa8756e337dfa7cec763a7d8496bf4838eb9ef88664b35512180f13cc4146e9816
+DIST yash-2.56.1.tar.xz 768752 BLAKE2B 8ee4c654e85b5895096870afcb3fc4e855274f3fd1956372753a46c522430a59c8ba96e64b0b13672e0289d2a9b6492a18a0f3d9e9e5500f53144ed1d56ca750 SHA512 28e8bde5fc12e5178136b82ecdc0c52c37c98301245089b0d55c43266880e299237a5522e572883e5c51b7d9a0e9bf94fe265a9ebdbf346c28ff837b0f60cc00
EBUILD yash-2.55.ebuild 809 BLAKE2B f840ca9db9255dad277f8fcc78fe4fc839db0754caa5c3aad6f20aabbacc91212271e28b3d42d42500897b06198db96e3e0be1be939e013dd2e432e42453fd92 SHA512 c3d9878f47f7571744814b39fd83d311fe58d74c3638516f1d48b2703312f8447693e292745149f672712a986fc98385dd6fd0123a4d07b076897199eb7c9755
+EBUILD yash-2.56.1.ebuild 844 BLAKE2B c91811fe1d24dc044ed26c2610015ef35dcb2d0ea11e58c7c0aefc09d4cf7d74336422a8238b6862bfd96f381ece8e5df0e2dd6d8ce3ffc7632a3da759a4cbfb SHA512 1b7ff8db51e0f55a47109671de85e54d341551e855ca749a503f1c0fb2b6b0b2190534c5f5a0caadfa75f57a808b7e4da9b21b8db59280302bf334dfff7322db
MISC metadata.xml 1065 BLAKE2B ab9ec0ac6fbf2666a7e987b6a4cfd62f8520f541eb0d900602a782f895757d85ab07f61ca60cfab3cd6042a4e24cb311eb17a4fc163c2652f3c9b7ec4f3cafa2 SHA512 1bf5664d53623cc41a2509662889fe967b62068b27d36f30152fb59de29b46af03ea5baa1a778b2dca6232ffe3d564db37a6432f5f8cdc585a8c88e87fc9ab9f
diff --git a/app-shells/yash/yash-2.56.1.ebuild b/app-shells/yash/yash-2.56.1.ebuild
new file mode 100644
index 000000000000..9084d796b0ba
--- /dev/null
+++ b/app-shells/yash/yash-2.56.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://magicant.github.io/yash/"
+SRC_URI="https://github.com/magicant/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}