summaryrefslogtreecommitdiff
path: root/app-shells/zsh/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-shells/zsh/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-shells/zsh/files')
-rw-r--r--app-shells/zsh/files/zprofile-44
-rw-r--r--app-shells/zsh/files/zsh-5.7.1-ncurses_colors.patch37
2 files changed, 2 insertions, 39 deletions
diff --git a/app-shells/zsh/files/zprofile-4 b/app-shells/zsh/files/zprofile-4
index b92c245784dd..9155aae3fc58 100644
--- a/app-shells/zsh/files/zprofile-4
+++ b/app-shells/zsh/files/zprofile-4
@@ -22,10 +22,10 @@ umask 022
# It is intentional in the following line to use || instead of -o.
# This way the evaluation can be short-circuited and calling whoami is
# avoided.
-if [[ "$EUID" = "0" ]] || [[ "$USER" = "root" ]] ; then
+if [[ "${EUID}" = "0" ]] || [[ "${USER}" = "root" ]] ; then
# Check to make sure ROOTPATH is sane before we use it.
# https://bugs.gentoo.org/656400
- if [[ :${ROOTPATH}: == *:/usr/sbin:* ]]; then
+ if [[ -n ${ROOTPATH} ]] && [[ :${ROOTPATH}: == *:/usr/sbin:* ]] ; then
PATH="${ROOTPATH}"
fi
fi
diff --git a/app-shells/zsh/files/zsh-5.7.1-ncurses_colors.patch b/app-shells/zsh/files/zsh-5.7.1-ncurses_colors.patch
deleted file mode 100644
index 3dc2a7d5a1af..000000000000
--- a/app-shells/zsh/files/zsh-5.7.1-ncurses_colors.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 7ce49801cc8ebc6f3a343ee5b829007f8cfb2bce Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Wed, 11 Dec 2019 14:56:25 +0100
-Subject: [PATCH] configure.ac: check for has_colors symbol in curses lib
-
-Otherwise zsh/curses module won't get built if ncurses was built with
-separate tinfo lib.
-One could still force-build the module but loading it later yields the
-following error message:
-
- failed to load module `zsh/curses': /usr/lib64/zsh/5.7.1/zsh/curses.so:
- undefined symbol: COLORS
-
-That is because the final linker call requires -lncurses(w) but it only
-contains -ltinfo(w).
-
-Reported-by: Tetja Rediske <tetja@tetja.de>
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- configure.ac | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/configure.ac b/configure.ac
-index 5513e25f1..792ad4db0 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -814,6 +814,7 @@ AC_SEARCH_LIBS(tgetent, [$termcap_curses_order],
- This is probably a library called 'curses' or 'ncurses'. You may
- need to install a package called 'curses-devel' or 'ncurses-devel' on your
- system."], 255))
-+AC_SEARCH_LIBS(has_colors, [$termcap_curses_order])
- AC_CHECK_HEADERS(curses.h, [],
- [AC_CACHE_CHECK(for Solaris 8 curses.h mistake, ac_cv_header_curses_solaris,
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <curses.h>]], [[]])],[ac_cv_header_curses_h=yes
---
-2.24.1
-