summaryrefslogtreecommitdiff
path: root/app-shells/zsh-completions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/zsh-completions
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/zsh-completions')
-rw-r--r--app-shells/zsh-completions/Manifest4
-rw-r--r--app-shells/zsh-completions/metadata.xml11
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.27.0.ebuild33
-rw-r--r--app-shells/zsh-completions/zsh-completions-9999.ebuild33
4 files changed, 81 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
new file mode 100644
index 000000000000..6ae1a562dc13
--- /dev/null
+++ b/app-shells/zsh-completions/Manifest
@@ -0,0 +1,4 @@
+DIST zsh-completions-0.27.0.tar.gz 218869 BLAKE2B 7214506be2100d596842988f946b0f25f9c434f31a6b1d66c40baa1ccf259f827be96011d790f41b85abecfcb0fc1e5d56a715ca80c9926a5fd6ccc779ab98b0 SHA512 1c25fce14117d6eb652e2d3bfb49e68baa9f7c5832031582ec8c3066b91f07491067ff887647177048b51146beda1bcac7080abf140ea5ef846fcdd8ac388b8c
+EBUILD zsh-completions-0.27.0.ebuild 796 BLAKE2B 5fb690109c0d4817be942e3484280d3a8ca9b90b6b643d1a80e4ac545ab4ada26decacc8beea9613641fce830f801909a5e23db904c45bedff2a084a27c3379a SHA512 8139a065b8eb26dccd1a07a72f5300f33a02355e5fea596fc5f2d1a7dd6301c82be6b9e99f9ee6bca9b3ec6094fbdb0904932d7793d34e40aa7461ea46326dde
+EBUILD zsh-completions-9999.ebuild 785 BLAKE2B 41e5cb4e18fc3947a5478e4927c1552ff20441d8e249f2589efbe2b1796d625381bb02d6180d8eae4c7e415b66aacdf386993089ba360ac4b039df8fee89f700 SHA512 6801846ac6ca49cded07839324e97ac8d32fbb46454b60e56dd0a5644d918bff08b316ebfd9e5cb4c5d96cd4d12d3f1644abfc3893062e9267964386b4f5a8e7
+MISC metadata.xml 345 BLAKE2B 6d43d457793d6548b98d393ec863c59a4f1fadf22cdc64b8366cc2f96f7b1899bb1924006e95d42db0609d72dd7664e743468c99eb2cecc9033a5a29867ac191 SHA512 e09a3412d8ea166270e3d6ce1d708cb989efa6889116d219ff76d96d0d92d533d7988504208ebc5e6a186327b6acc4e8b2c719c21c86bd84154292f6eac4a430
diff --git a/app-shells/zsh-completions/metadata.xml b/app-shells/zsh-completions/metadata.xml
new file mode 100644
index 000000000000..d1f5bfca20a4
--- /dev/null
+++ b/app-shells/zsh-completions/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zsh-users/zsh-completions</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/zsh-completions/zsh-completions-0.27.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.27.0.ebuild
new file mode 100644
index 000000000000..f59a24150fa9
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.27.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~sparc ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}
diff --git a/app-shells/zsh-completions/zsh-completions-9999.ebuild b/app-shells/zsh-completions/zsh-completions-9999.ebuild
new file mode 100644
index 000000000000..3ba0582d57d7
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}