summaryrefslogtreecommitdiff
path: root/app-shells/psh/psh-1.8.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-shells/psh/psh-1.8.1-r4.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-shells/psh/psh-1.8.1-r4.ebuild')
-rw-r--r--app-shells/psh/psh-1.8.1-r4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-shells/psh/psh-1.8.1-r4.ebuild b/app-shells/psh/psh-1.8.1-r4.ebuild
new file mode 100644
index 000000000000..9e7a280fb0c5
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_EXAMPLES=( "examples/*" )
+
+inherit optfeature perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="https://gnp.github.io/psh/"
+SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${P}
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-r3-defined-array.patch
+ "${FILESDIR}"/${P}-r3-array-ref-deprecated.patch
+)
+
+src_install() {
+ myinst="SITEPREFIX=${D}/usr"
+
+ perl-module_src_install
+
+ docompress -x /usr/share/doc/${PF}/pod
+
+ docinto pod/
+ dodoc -r doc/*
+}
+
+pkg_postinst() {
+ optfeature "ulimit functionality" dev-perl/BSD-Resource
+}