summaryrefslogtreecommitdiff
path: root/app-shells/psh/psh-1.8.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/psh/psh-1.8.1-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/psh/psh-1.8.1-r3.ebuild')
-rw-r--r--app-shells/psh/psh-1.8.1-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/psh/psh-1.8.1-r3.ebuild b/app-shells/psh/psh-1.8.1-r3.ebuild
new file mode 100644
index 000000000000..00fa615132c7
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_EXAMPLES=( "examples/*" )
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="https://gnp.github.io/psh/"
+SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${P}" # github--
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+myinst="SITEPREFIX=${D}/usr"
+
+PATCHES=(
+ "${FILESDIR}/${PF}-defined-array.patch"
+ "${FILESDIR}/${PF}-array-ref-deprecated.patch"
+)
+
+src_install() {
+ perl-module_src_install
+ docompress -x "/usr/share/doc/${PF}/pod"
+ docinto pod/
+ dodoc -r doc/*
+}