summaryrefslogtreecommitdiff
path: root/app-shells/psh/psh-1.8.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/psh/psh-1.8.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/psh/psh-1.8.1-r3.ebuild')
-rw-r--r--app-shells/psh/psh-1.8.1-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/psh/psh-1.8.1-r3.ebuild b/app-shells/psh/psh-1.8.1-r3.ebuild
new file mode 100644
index 000000000000..00fa615132c7
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_EXAMPLES=( "examples/*" )
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="https://gnp.github.io/psh/"
+SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${P}" # github--
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+myinst="SITEPREFIX=${D}/usr"
+
+PATCHES=(
+ "${FILESDIR}/${PF}-defined-array.patch"
+ "${FILESDIR}/${PF}-array-ref-deprecated.patch"
+)
+
+src_install() {
+ perl-module_src_install
+ docompress -x "/usr/share/doc/${PF}/pod"
+ docinto pod/
+ dodoc -r doc/*
+}