summaryrefslogtreecommitdiff
path: root/app-shells/posh/posh-0.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /app-shells/posh/posh-0.13.1.ebuild
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'app-shells/posh/posh-0.13.1.ebuild')
-rw-r--r--app-shells/posh/posh-0.13.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-shells/posh/posh-0.13.1.ebuild b/app-shells/posh/posh-0.13.1.ebuild
index b9d6fe69c69b..cabbfd2573a2 100644
--- a/app-shells/posh/posh-0.13.1.ebuild
+++ b/app-shells/posh/posh-0.13.1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools
+
DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
HOMEPAGE="https://salsa.debian.org/clint/posh"
SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.xz"
@@ -16,6 +18,12 @@ DEPEND="app-arch/xz-utils"
S=${WORKDIR}/posh
+src_prepare() {
+ default
+ # the tarball apparently contains outdated files
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--exec-prefix="${EPREFIX:-/}"