summaryrefslogtreecommitdiff
path: root/app-shells/posh-z
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /app-shells/posh-z
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'app-shells/posh-z')
-rw-r--r--app-shells/posh-z/Manifest3
-rw-r--r--app-shells/posh-z/metadata.xml13
-rw-r--r--app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/app-shells/posh-z/Manifest b/app-shells/posh-z/Manifest
new file mode 100644
index 000000000000..c4eedfb0cc85
--- /dev/null
+++ b/app-shells/posh-z/Manifest
@@ -0,0 +1,3 @@
+DIST posh-z-1.1.12_p20230811.tar.gz 290155 BLAKE2B 227d14c947daf121d013e4ad020a80935c87fd198e57e486d0f3598ef9c7d72d660e61b9576fecc6635226a47388d2eb9ea785762436fd177a74eeb867ad4095 SHA512 91d2173205ef5d27e9385ed5a09e6809be284488e69e4d6ca85019cdf0abfac26aaa01765c52eaee85aacd367982510bad5b3881ca3679f2e8ba19101db3cd50
+EBUILD posh-z-1.1.12_p20230811.ebuild 898 BLAKE2B d4deac861bb818de466521a28b0eae3fffd8b5412597b60b8a660d0f36dd4199526dc4432576a559e9cd05eda604a9850959b7c81dc8059f0fd862993479842c SHA512 9bfc6d53ef6d6a5beed1d38325ad003f4c6bb1b62d980b039db458f359828b54db3e40c10537662a1b11ce76a407cd0e58acc5a220076add309bab8cb93f3e69
+MISC metadata.xml 415 BLAKE2B 54ab9fc29b5dcb669179d0041f0c936eb48c43b543567e997e93f74542238a33b09375304c3dffddb1058c92e839b19198dde94d279f588e0fbf244141d72d3c SHA512 3ef0a77ce423846c09db047deb497e4a1e3e870f222b60d88df320945af0250766c7a265772788249ff0eda46beff28981bf17ff3cd5333632cf0e4f5566e189
diff --git a/app-shells/posh-z/metadata.xml b/app-shells/posh-z/metadata.xml
new file mode 100644
index 000000000000..b3ffc98a0269
--- /dev/null
+++ b/app-shells/posh-z/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/badmotorfinger/z/issues/</bugs-to>
+ <remote-id type="github">badmotorfinger/z</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild b/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild
new file mode 100644
index 000000000000..9992bd48a310
--- /dev/null
+++ b/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Quickly navigate the file system based on your cd history"
+HOMEPAGE="https://github.com/badmotorfinger/z/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/badmotorfinger/z.git"
+else
+ if [[ "${PV}" == *_p20230811 ]] ; then
+ COMMIT="ca1c8d9f004eede2ba907da199bde542d9eff344"
+
+ SRC_URI="https://github.com/badmotorfinger/z/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/z-${COMMIT}"
+ else
+ SRC_URI="https://github.com/badmotorfinger/z/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/z-${PV}"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="public-domain"
+SLOT="${PV%%_p*}"
+
+RDEPEND="virtual/pwsh:*"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/z/${SLOT}"
+ doins z.*
+
+ einstalldocs
+}