summaryrefslogtreecommitdiff
path: root/app-shells/mpibash/mpibash-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-shells/mpibash/mpibash-1.3-r1.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-shells/mpibash/mpibash-1.3-r1.ebuild')
-rw-r--r--app-shells/mpibash/mpibash-1.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/mpibash/mpibash-1.3-r1.ebuild b/app-shells/mpibash/mpibash-1.3-r1.ebuild
new file mode 100644
index 000000000000..fcb33db81ee9
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2:0[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/mpi-3.patch" )
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}