summaryrefslogtreecommitdiff
path: root/app-shells/mpibash/mpibash-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/mpibash/mpibash-1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/mpibash/mpibash-1.2.ebuild')
-rw-r--r--app-shells/mpibash/mpibash-1.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/mpibash/mpibash-1.2.ebuild b/app-shells/mpibash/mpibash-1.2.ebuild
new file mode 100644
index 000000000000..594ac6bc88cb
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}