summaryrefslogtreecommitdiff
path: root/app-shells/loksh/loksh-6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-shells/loksh/loksh-6.4.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-shells/loksh/loksh-6.4.ebuild')
-rw-r--r--app-shells/loksh/loksh-6.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-6.4.ebuild b/app-shells/loksh/loksh-6.4.ebuild
new file mode 100644
index 000000000000..24cedba7c6b3
--- /dev/null
+++ b/app-shells/loksh/loksh-6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}
+ !app-shells/ksh"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ BIN_DIR="${EROOT}/bin" \
+ DESTDIR="${D}" \
+ DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+
+ dodoc NOTES
+}