summaryrefslogtreecommitdiff
path: root/app-shells/linuxinfo/linuxinfo-0.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 01:37:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 01:37:43 +0000
commite67d5b4ba05349b3bf4229d0cf7d069809c4420e (patch)
tree0fe2174d8edf159924d772ad279f37faba8d5b6a /app-shells/linuxinfo/linuxinfo-0.0.8.ebuild
parent249ae8c1a241b514fc83737660927ee175091346 (diff)
gentoo auto-resync : 28:12:2023 - 01:37:43
Diffstat (limited to 'app-shells/linuxinfo/linuxinfo-0.0.8.ebuild')
-rw-r--r--app-shells/linuxinfo/linuxinfo-0.0.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/linuxinfo/linuxinfo-0.0.8.ebuild b/app-shells/linuxinfo/linuxinfo-0.0.8.ebuild
new file mode 100644
index 000000000000..a09d370edb7e
--- /dev/null
+++ b/app-shells/linuxinfo/linuxinfo-0.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Get useful linux system information using PowerShell"
+HOMEPAGE="https://github.com/ehmiiz/linuxinfo/"
+SRC_URI="https://www.powershellgallery.com/api/v2/package/${PN}/${PV}
+ -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ virtual/pwsh:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm -f -r '[Content_Types].xml' _rels package || die
+}
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins -r .
+}