summaryrefslogtreecommitdiff
path: root/app-shells/irregular/irregular-0.7.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-19 00:49:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-19 00:49:58 +0000
commit2c18b7f7fb2885d27960657c60906ef0bac0681e (patch)
tree91c24c33362baf968c4c08f3a7220157b57a374f /app-shells/irregular/irregular-0.7.8.ebuild
parentbc7e0dbdbd194a8c2e09f82e1a5a4ea5e1b556f4 (diff)
gentoo auto-resync : 19:03:2024 - 00:49:58
Diffstat (limited to 'app-shells/irregular/irregular-0.7.8.ebuild')
-rw-r--r--app-shells/irregular/irregular-0.7.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/irregular/irregular-0.7.8.ebuild b/app-shells/irregular/irregular-0.7.8.ebuild
new file mode 100644
index 000000000000..fbaf088f26c5
--- /dev/null
+++ b/app-shells/irregular/irregular-0.7.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell module that helps to understand, use, and build regular expressions"
+HOMEPAGE="https://irregular.start-automating.com/
+ https://github.com/StartAutomating/Irregular/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/StartAutomating/${PN^}.git"
+else
+ SRC_URI="https://github.com/StartAutomating/${PN^}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P^}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="virtual/pwsh:*"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN^}/${PV}"
+ doins "${PN^}.psd1"
+ doins *.ps1 *.ps1xml *.psm1
+ doins -r Formatting RegEx Types en-us
+
+ dodoc *.md
+}