summaryrefslogtreecommitdiff
path: root/app-shells/hstr/hstr-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-12 23:47:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-12 23:47:29 +0000
commit175512fa7c74d0e48a7a1b40a6e456435af0481b (patch)
treeefa41b58f0ed5e41f23180a34d30d1cf928be390 /app-shells/hstr/hstr-2.6.ebuild
parent4d3b8f8b38eda2e6cfa39c2efcf4f9c4055c2d7d (diff)
gentoo auto-resync : 12:01:2023 - 23:47:29
Diffstat (limited to 'app-shells/hstr/hstr-2.6.ebuild')
-rw-r--r--app-shells/hstr/hstr-2.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-2.6.ebuild b/app-shells/hstr/hstr-2.6.ebuild
new file mode 100644
index 000000000000..6a4a7749524a
--- /dev/null
+++ b/app-shells/hstr/hstr-2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)]"
+
+DEPEND="
+ ${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-ncurses-configure.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
+ eautoreconf
+}