summaryrefslogtreecommitdiff
path: root/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild')
-rw-r--r--app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
new file mode 100644
index 000000000000..6e939fa84091
--- /dev/null
+++ b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+# slightly broken
+RESTRICT="test"
+
+DESCRIPTION="Heirloom Bourne Shell, derived from OpenSolaris code SVR4/SVID3"
+HOMEPAGE="http://heirloom.sourceforge.net/sh.html"
+SRC_URI="mirror://sourceforge/heirloom/${P}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}" \
+ "LARGEF=" \
+ "CC=$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ newexe sh jsh
+ newman sh.1 jsh.1
+}