summaryrefslogtreecommitdiff
path: root/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild')
-rw-r--r--app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
new file mode 100644
index 000000000000..6e939fa84091
--- /dev/null
+++ b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+# slightly broken
+RESTRICT="test"
+
+DESCRIPTION="Heirloom Bourne Shell, derived from OpenSolaris code SVR4/SVID3"
+HOMEPAGE="http://heirloom.sourceforge.net/sh.html"
+SRC_URI="mirror://sourceforge/heirloom/${P}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}" \
+ "LARGEF=" \
+ "CC=$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ newexe sh jsh
+ newman sh.1 jsh.1
+}