summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild')
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild
new file mode 100644
index 000000000000..ac89d477c103
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20220112.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}