summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild')
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild
new file mode 100644
index 000000000000..8e4ce74b2707
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-bashcomp.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}