summaryrefslogtreecommitdiff
path: root/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild')
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild
new file mode 100644
index 000000000000..9b9190536b91
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20101217-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils prefix
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~darkside/tmp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND="app-shells/bash-completion"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-make_globals.patch" #431034
+ eprefixify gentoo
+}
+
+src_compile() { :; } # There is a useless Makefile in the distfile
+
+src_install() {
+ insinto /usr/share/bash-completion
+ doins gentoo || die "failed to install gentoo module"
+ doins repoman || die "failed to install repoman module"
+ doins layman || die "failed to install layman module"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ # can't use bash-completion.eclass.
+ elog "To enable command-line completion for ${PN}, run:"
+ elog
+ elog " eselect bashcomp enable gentoo"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global gentoo"
+ elog
+ elog "to install system-wide. (and/or repoman instead of gentoo if you use"
+ elog "repoman frequently)"
+}