summaryrefslogtreecommitdiff
path: root/app-shells/fzy/fzy-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /app-shells/fzy/fzy-9999.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'app-shells/fzy/fzy-9999.ebuild')
-rw-r--r--app-shells/fzy/fzy-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-shells/fzy/fzy-9999.ebuild b/app-shells/fzy/fzy-9999.ebuild
new file mode 100644
index 000000000000..bbf7b6adbe55
--- /dev/null
+++ b/app-shells/fzy/fzy-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jhawthorn/fzy.git"
+else
+ SRC_URI="https://github.com/jhawthorn/fzy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}"/fzy-0.9-cflags.patch )
+
+src_prepare() {
+ default
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ exeinto /usr/share/fzy
+ doexe contrib/fzy-tmux
+ doexe contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}