summaryrefslogtreecommitdiff
path: root/app-shells/fzf/fzf-0.28.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-20 02:40:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-20 02:40:19 +0100
commit2d5fd1dd4910d46f935776f1f6f475de11367ef2 (patch)
tree42bc589da04de88a86fd2950f9c66360ee79328e /app-shells/fzf/fzf-0.28.0.ebuild
parent54eca75a4e3e380e1d386f4d235baeb7d4ff332e (diff)
gentoo auto-resync : 20:07:2022 - 02:40:19
Diffstat (limited to 'app-shells/fzf/fzf-0.28.0.ebuild')
-rw-r--r--app-shells/fzf/fzf-0.28.0.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/app-shells/fzf/fzf-0.28.0.ebuild b/app-shells/fzf/fzf-0.28.0.ebuild
deleted file mode 100644
index 642b91397e62..000000000000
--- a/app-shells/fzf/fzf-0.28.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
-HOMEPAGE="https://github.com/junegunn/fzf"
-
-# For fancy versioning only. Bump on the next release!
-MY_GIT_REV=e4c3ecc
-
-EGO_SUM=(
- "github.com/gdamore/encoding v1.0.0"
- "github.com/gdamore/encoding v1.0.0/go.mod"
- "github.com/gdamore/tcell v1.4.0"
- "github.com/gdamore/tcell v1.4.0/go.mod"
- "github.com/lucasb-eyer/go-colorful v1.0.3/go.mod"
- "github.com/lucasb-eyer/go-colorful v1.2.0"
- "github.com/lucasb-eyer/go-colorful v1.2.0/go.mod"
- "github.com/mattn/go-isatty v0.0.14"
- "github.com/mattn/go-isatty v0.0.14/go.mod"
- "github.com/mattn/go-runewidth v0.0.7/go.mod"
- "github.com/mattn/go-runewidth v0.0.13"
- "github.com/mattn/go-runewidth v0.0.13/go.mod"
- "github.com/mattn/go-shellwords v1.0.12"
- "github.com/mattn/go-shellwords v1.0.12/go.mod"
- "github.com/rivo/uniseg v0.2.0"
- "github.com/rivo/uniseg v0.2.0/go.mod"
- "github.com/saracen/walker v0.1.2"
- "github.com/saracen/walker v0.1.2/go.mod"
- "golang.org/x/sync v0.0.0-20200317015054-43a5402ce75a/go.mod"
- "golang.org/x/sync v0.0.0-20210220032951-036812b2e83c"
- "golang.org/x/sync v0.0.0-20210220032951-036812b2e83c/go.mod"
- "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756/go.mod"
- "golang.org/x/sys v0.0.0-20201119102817-f84b799fce68/go.mod"
- "golang.org/x/sys v0.0.0-20210630005230-0f9fa26af87c"
- "golang.org/x/sys v0.0.0-20210630005230-0f9fa26af87c/go.mod"
- "golang.org/x/term v0.0.0-20210317153231-de623e64d2a6"
- "golang.org/x/term v0.0.0-20210317153231-de623e64d2a6/go.mod"
- "golang.org/x/text v0.3.0/go.mod"
- "golang.org/x/text v0.3.6"
- "golang.org/x/text v0.3.6/go.mod"
- "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
-)
-
-go-module_set_globals
-
-SRC_URI="
- https://github.com/junegunn/fzf/archive/${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_SUM_SRC_URI}
-"
-
-LICENSE="MIT BSD-with-disclosure"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-
-src_prepare() {
- default
- sed -i 's/-s -w //' Makefile || die # bug 795225
-}
-
-src_compile() {
- emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
-}
-
-src_install() {
- dobin bin/${PN}
- doman man/man1/${PN}.1
-
- dobin bin/${PN}-tmux
- doman man/man1/${PN}-tmux.1
-
- insinto /usr/share/vim/vimfiles/plugin
- doins plugin/${PN}.vim
-
- insinto /usr/share/nvim/runtime/plugin
- doins plugin/${PN}.vim
-
- newbashcomp shell/completion.bash ${PN}
-
- insinto /usr/share/zsh/site-functions
- newins shell/completion.zsh _${PN}
-
- insinto /usr/share/fzf
- doins shell/key-bindings.bash
- doins shell/key-bindings.fish
- doins shell/key-bindings.zsh
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To add fzf support to your shell, make sure to use the right file"
- elog "from /usr/share/fzf."
- elog
- elog "For bash, add the following line to ~/.bashrc:"
- elog
- elog " # source /usr/share/bash-completion/completions/fzf"
- elog " # source /usr/share/fzf/key-bindings.bash"
- elog
- elog "Plugins for Vim and Neovim are installed to respective directories"
- elog "and will work out of the box."
- elog
- elog "For fzf support in tmux see fzf-tmux(1)."
- fi
-}