summaryrefslogtreecommitdiff
path: root/app-shells/fish/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /app-shells/fish/files
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'app-shells/fish/files')
-rw-r--r--app-shells/fish/files/3.3.1-don-t-override-linker.patch48
-rw-r--r--app-shells/fish/files/3.3.1-sbin-path-sh-test.patch25
2 files changed, 73 insertions, 0 deletions
diff --git a/app-shells/fish/files/3.3.1-don-t-override-linker.patch b/app-shells/fish/files/3.3.1-don-t-override-linker.patch
new file mode 100644
index 000000000000..cb67498fd2ba
--- /dev/null
+++ b/app-shells/fish/files/3.3.1-don-t-override-linker.patch
@@ -0,0 +1,48 @@
+From c9ab706be64439d1a03f978d3a47450135c87002 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <ya@sysdump.net>
+Date: Tue, 29 Jun 2021 09:40:44 -0700
+Subject: [PATCH] don't override linker
+
+---
+ CMakeLists.txt | 18 +-----------------
+ 1 file changed, 1 insertion(+), 17 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fda837cd3..507dc8817 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -56,22 +56,6 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra \
+ # Disable exception handling.
+ add_compile_options(-fno-exceptions)
+
+-# Prefer lld or the gold linker because they don't emit useless warnings about sys_nerr and
+-# _sys_errlist. They're also faster (significantly so in the case of lld).
+-if (UNIX)
+- execute_process(COMMAND ${CMAKE_C_COMPILER} -fuse-ld=lld -Wl,--version
+- ERROR_QUIET OUTPUT_VARIABLE LD_VERSION)
+- if ("${LD_VERSION}" MATCHES "LLD ")
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fuse-ld=lld")
+- elseif (NOT APPLE)
+- execute_process(COMMAND ${CMAKE_C_COMPILER} -fuse-ld=gold -Wl,--version
+- ERROR_QUIET OUTPUT_VARIABLE LD_VERSION)
+- if ("${LD_VERSION}" MATCHES "GNU gold")
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fuse-ld=gold")
+- endif()
+- endif()
+-endif()
+-
+ # Hide the CMake Rules directories in Xcode projects.
+ source_group("CMake Rules" REGULAR_EXPRESSION "^$")
+
+@@ -128,7 +112,7 @@ set(FISH_SRCS
+ src/proc.cpp src/reader.cpp src/redirection.cpp src/sanity.cpp src/screen.cpp
+ src/signal.cpp src/termsize.cpp src/timer.cpp src/tinyexpr.cpp
+ src/tokenizer.cpp src/topic_monitor.cpp src/trace.cpp src/utf8.cpp src/util.cpp
+- src/wait_handle.cpp src/wcstringutil.cpp src/wgetopt.cpp src/wildcard.cpp
++ src/wait_handle.cpp src/wcstringutil.cpp src/wgetopt.cpp src/wildcard.cpp
+ src/wutil.cpp src/fds.cpp
+ )
+
+--
+2.32.0
+
diff --git a/app-shells/fish/files/3.3.1-sbin-path-sh-test.patch b/app-shells/fish/files/3.3.1-sbin-path-sh-test.patch
new file mode 100644
index 000000000000..ce66e98eb124
--- /dev/null
+++ b/app-shells/fish/files/3.3.1-sbin-path-sh-test.patch
@@ -0,0 +1,25 @@
+From 1f73c8d923e41442cefd5a58498798971282c701 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <ya@sysdump.net>
+Date: Tue, 29 Jun 2021 09:55:14 -0700
+Subject: [PATCH] sbin path sh test
+
+---
+ tests/checks/type.fish | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/checks/type.fish b/tests/checks/type.fish
+index 85a2d142a..6ce3a4f68 100644
+--- a/tests/checks/type.fish
++++ b/tests/checks/type.fish
+@@ -31,7 +31,7 @@ echo $status
+ # Test that we print a command path
+ type sh
+ # (we resolve the path, so if /bin is a symlink to /usr/bin this shows /usr/bin/sh)
+-# CHECK: sh is {{.*}}/bin/sh
++# CHECK: sh is {{.*}}/{{s*}}bin/sh
+
+ # Test that we print a function definition.
+ # The exact definition and description here depends on the system, so we'll ignore the actual code.
+--
+2.32.0
+