summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-4.3_p48-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-shells/bash/bash-4.3_p48-r2.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-shells/bash/bash-4.3_p48-r2.ebuild')
-rw-r--r--app-shells/bash/bash-4.3_p48-r2.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/app-shells/bash/bash-4.3_p48-r2.ebuild b/app-shells/bash/bash-4.3_p48-r2.ebuild
index 14f08b6aed1d..d013a6fda2ae 100644
--- a/app-shells/bash/bash-4.3_p48-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p48-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib
+inherit flag-o-matic toolchain-funcs
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-4.3-patches/
@@ -45,24 +45,26 @@ DEPEND=">=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )"
RDEPEND="${DEPEND}
!<sys-apps/portage-2.1.6.7_p1"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
BDEPEND="virtual/yacc"
PATCHES=(
"${FILESDIR}"/${PN}-4.3-mapfile-improper-array-name-validation.patch
"${FILESDIR}"/${PN}-4.3-arrayfunc.patch
"${FILESDIR}"/${PN}-4.3-protos.patch
- "${FILESDIR}"/${PN}-4.4-popd-offset-overflow.patch #600174
+ "${FILESDIR}"/${PN}-4.4-popd-offset-overflow.patch # bug #600174
)
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -84,7 +86,7 @@ src_prepare() {
sed -ri -e 's:\$[{(](RL|HIST)_LIBSRC[)}]/[[:alpha:]_-]*\.h::g' Makefile.in || die
fi
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -95,7 +97,13 @@ src_configure() {
local myconf=(
--docdir='$(datarootdir)'/doc/${PF}
--htmldir='$(docdir)/html'
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -119,7 +127,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -133,28 +141,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if [[ ${PV} != *_rc* ]] ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}