summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-4.1_p17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-shells/bash/bash-4.1_p17.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-shells/bash/bash-4.1_p17.ebuild')
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index da915e1f0dd5..7ae8ac6934df 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -46,14 +46,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-4.1-fbsd-eaccess.patch #303411
+ "${FILESDIR}"/${PN}-4.1-fbsd-eaccess.patch #bug #303411
"${FILESDIR}"/${PN}-4.1-parallel-build.patch
- "${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -81,7 +82,16 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
+ # bug #335896
+ --without-lispdir
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -92,8 +102,6 @@ src_configure() {
$(use_enable readline bang-history)
)
- myconf+=( --without-lispdir ) #335896
-
# For descriptions of these, see config-top.h
# bashrc/#26952 bash_logout/#90488 ssh/#24762 mktemp/#574426
append-cppflags \
@@ -117,12 +125,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}