summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-4.0_p44.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-shells/bash/bash-4.0_p44.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-shells/bash/bash-4.0_p44.ebuild')
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index 2814366f9f94..c66b53fb1d0c 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -46,18 +46,19 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-4.0-configure.patch #304901
+ "${FILESDIR}"/${PN}-4.0-configure.patch # bug #304901
"${FILESDIR}"/${PN}-4.x-deferred-heredocs.patch
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
- "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch #211947
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
+ "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch # bug #211947
"${FILESDIR}"/${PN}-4.0-negative-return.patch
- "${FILESDIR}"/${PN}-4.0-parallel-build.patch #267613
+ "${FILESDIR}"/${PN}-4.0-parallel-build.patch # bug #267613
"${FILESDIR}"/${PN}-4.2-dev-fd-buffer-overflow.patch #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -80,13 +81,19 @@ src_prepare() {
default
sed -i '1i#define NEED_FPURGE_DECL' execute_cmd.c || die # needs fpurge() decl
- sed -i '/\.o: .*shell\.h/s:$: pathnames.h:' Makefile.in || die #267613
+ sed -i '/\.o: .*shell\.h/s:$: pathnames.h:' Makefile.in || die # bug #267613
}
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -120,12 +127,9 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
econf "${myconf[@]}"
}