summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-3.1_p23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /app-shells/bash/bash-3.1_p23.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'app-shells/bash/bash-3.1_p23.ebuild')
-rw-r--r--app-shells/bash/bash-3.1_p23.ebuild70
1 files changed, 36 insertions, 34 deletions
diff --git a/app-shells/bash/bash-3.1_p23.ebuild b/app-shells/bash/bash-3.1_p23.ebuild
index 05a7f9dd6087..ad1a7e46c428 100644
--- a/app-shells/bash/bash-3.1_p23.ebuild
+++ b/app-shells/bash/bash-3.1_p23.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
+PLEVEL="${PV##*_p}"
+MY_PV="${PV/_p*}"
+MY_PV="${MY_PV/_/-}"
+MY_P="${PN}-${MY_PV}"
[[ ${PV} != *_p* ]] && PLEVEL=0
patches() {
- local opt=$1 plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
+ local opt=${1} plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
[[ ${plevel} -eq 0 ]] && return 1
eval set -- {1..${plevel}}
set -- $(printf "${pn}${pv/\.}-%03d " "$@")
@@ -43,7 +43,19 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
+ "${FILESDIR}"/${PN}-3.1-protos.patch
+ "${FILESDIR}"/${PN}-3.1-ulimit.patch
+ "${FILESDIR}"/${PN}-3.0-read-memleak.patch
+ "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
+ "${FILESDIR}"/${PN}-3.1-fix-dash-login-shell.patch #118257
+ "${FILESDIR}"/${PN}-3.1-dev-fd-test-as-user.patch #131875
+ "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
+)
pkg_setup() {
if is-flag -malign-double ; then #7332
@@ -59,28 +71,28 @@ src_unpack() {
src_prepare() {
# Include official patches
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
+ [[ ${PLEVEL} -gt 0 ]] && eapply -p0 $(patches -s)
# Clean out local libs so we know we use system ones
- rm -rf lib/{readline,termcap}/*
- touch lib/{readline,termcap}/Makefile.in # for config.status
+ rm -rf lib/{readline,termcap}/* || die
+ touch lib/{readline,termcap}/Makefile.in || die # for config.status
sed -ri -e 's:\$[(](RL|HIST)_LIBSRC[)]/[[:alpha:]]*.h::g' Makefile.in || die
- epatch "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
- epatch "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
- epatch "${FILESDIR}"/${PN}-3.1-protos.patch
- epatch "${FILESDIR}"/${PN}-3.1-ulimit.patch
- epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
- epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- epatch "${FILESDIR}"/${PN}-3.1-fix-dash-login-shell.patch #118257
- epatch "${FILESDIR}"/${PN}-3.1-dev-fd-test-as-user.patch #131875
- epatch "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
-
- epatch_user
+ default
}
src_configure() {
- local myconf=()
+ local myconf=(
+ --with-installed-readline=.
+ --with-curses
+ $(use_with afs)
+ $(use_enable net net-redirections)
+ --disable-profiling
+ --without-gnu-malloc
+ $(use_enable readline)
+ $(use_enable readline history)
+ $(use_enable readline bang-history)
+ )
# Force pgrp synchronization
# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653
@@ -115,17 +127,7 @@ src_configure() {
# ncurses in one or two small places :(.
tc-export AR #444070
- econf \
- --with-installed-readline=. \
- --with-curses \
- $(use_with afs) \
- $(use_enable net net-redirections) \
- --disable-profiling \
- --without-gnu-malloc \
- $(use_enable readline) \
- $(use_enable readline history) \
- $(use_enable readline bang-history) \
- "${myconf[@]}"
+ econf "${myconf[@]}"
}
src_install() {