summaryrefslogtreecommitdiff
path: root/app-shells/bash-completion/bash-completion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /app-shells/bash-completion/bash-completion-9999.ebuild
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'app-shells/bash-completion/bash-completion-9999.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild28
1 files changed, 25 insertions, 3 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index d9a8954d6f32..322f3a72d214 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -13,7 +13,6 @@ EGIT_REPO_URI="https://github.com/scop/bash-completion"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
IUSE="+eselect test"
RESTRICT="!test? ( test )"
@@ -21,6 +20,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
+ !<app-text/tree-2.1.1-r1
!!net-fs/mc
"
BDEPEND="
@@ -29,6 +29,8 @@ BDEPEND="
$(python_gen_any_dep '
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
')
)
"
@@ -69,7 +71,9 @@ strip_completions() {
python_check_deps() {
python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest-forked[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"
}
pkg_setup() {
@@ -102,7 +106,16 @@ src_test() {
test/t/test_if{down,up}.py
# not available for icedtea
test/t/test_javaws.py
+ # TODO
+ test/t/test_vi.py::TestVi::test_2
+ test/t/test_xmlwf.py::TestXmlwf::test_2 #bug 886159
+ test/t/test_xrandr.py::TestXrandr::test_output_filter
)
+ local EPYTEST_IGNORE=(
+ # stupid test that async tests work
+ test/fixtures/pytest/test_async.py
+ )
+ local EPYTEST_XDIST=1
# portage's HOME override breaks tests
local -x HOME=$(unset HOME; echo ~)
@@ -110,6 +123,7 @@ src_test() {
# used in pytest tests
local -x NETWORK=none
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked
emake -C completions check
epytest
}
@@ -122,7 +136,15 @@ src_install() {
strip_completions
- dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
+ dodoc AUTHORS CHANGELOG.md CONTRIBUTING.md README.md
+
+ # install the python completions for all targets, bug #622892
+ local TARGET
+ for TARGET in "${PYTHON_COMPAT[@]}"; do
+ if [[ ! -e "${ED}"/usr/share/bash-completion/completions/${TARGET/_/.} ]]; then
+ dosym python "${ED}"/usr/share/bash-completion/completions/${TARGET/_/.}
+ fi
+ done
# install the eselect module
if use eselect; then