summaryrefslogtreecommitdiff
path: root/app-shells/bash-completion/bash-completion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /app-shells/bash-completion/bash-completion-9999.ebuild
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'app-shells/bash-completion/bash-completion-9999.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 10f64b1c2271..1ef70643b1e9 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -45,8 +45,8 @@ STRIP_COMPLETIONS=(
# Now-dead symlinks to deprecated completions
hd ncal
- # Installed by sys-apps/util-linux-2.28
- mount umount mount.linux umount.linux
+ # Installed by sys-apps/util-linux-2.28 (and now deprecated)
+ _mount _umount _mount.linux _umount.linux
# Deprecated in favor of sys-apps/util-linux-2.31
_rfkill
@@ -95,7 +95,8 @@ src_install() {
local file
for file in "${STRIP_COMPLETIONS[@]}"; do
- rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ rm "${ED}"/usr/share/bash-completion/completions/${file} ||
+ die "stripping ${file} failed"
done
# remove deprecated completions (moved to other packages)
rm "${ED}"/usr/share/bash-completion/completions/_* || die