summaryrefslogtreecommitdiff
path: root/app-shells/bash-completion/bash-completion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /app-shells/bash-completion/bash-completion-9999.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'app-shells/bash-completion/bash-completion-9999.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 79ee3e0ac0af..766299412c53 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -4,20 +4,22 @@
EAPI=6
BASHCOMP_P=bashcomp-2.0.2
-EGIT_REPO_URI="https://github.com/scop/bash-completion"
-inherit autotools eapi7-ver git-r3
+PYTHON_COMPAT=( python3_{5,6} )
+inherit autotools eapi7-ver git-r3 python-any-r1
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
+EGIT_REPO_URI="https://github.com/scop/bash-completion"
SRC_URI="https://bitbucket.org/mgorny/bashcomp2/downloads/${BASHCOMP_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
IUSE="test"
+RESTRICT="!test? ( test )"
# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1
+RDEPEND=">=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
!app-eselect/eselect-bashcomp
!!net-fs/mc"
@@ -27,6 +29,10 @@ DEPEND="app-arch/xz-utils
app-misc/dtach
dev-util/dejagnu
dev-tcltk/tcllib
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
)"
PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
@@ -52,6 +58,11 @@ STRIP_COMPLETIONS=(
_rfkill
)
+python_check_deps() {
+ has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
src_unpack() {
git-r3_src_unpack
default