summaryrefslogtreecommitdiff
path: root/app-portage/unsymlink-lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-portage/unsymlink-lib
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-portage/unsymlink-lib')
-rw-r--r--app-portage/unsymlink-lib/Manifest2
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-19.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
index 43cd9b0218d0..ea0c7a42ecb6 100644
--- a/app-portage/unsymlink-lib/Manifest
+++ b/app-portage/unsymlink-lib/Manifest
@@ -1,3 +1,5 @@
DIST unsymlink-lib-18.tar.gz 10807 BLAKE2B 0c15ba8fadc96641139db68068c6402f24bd9129b452a8996c393ee899b274e7a5c96d58c2745b74ec3dbb469008a6756041b153abbbe3f29aca5f93c8700834 SHA512 bb08f1c35046d756aee752c7cd28f8eb93c562587f2fbc0070817c11fd42f3d12fade9c8ad29c508813e10993f5b622c9d33da52e49dfa7e16b1997a72d491f5
+DIST unsymlink-lib-19.tar.gz 11235 BLAKE2B 955583517c485125722bdc808e1038c038509fad0afe0774f16299f2eb3a6088d7433e11565567bb3c9976a27910fbd9fe92289eaa210062f38eb9e3b15e120b SHA512 98943c887aeb70fc667c2092b985fe0078f127123d271cc45e1abb3e9b6218f1190bd23f140fa9775dca1d473d03113e6cfa8aeca8985cfc31f1cb459c4c620e
EBUILD unsymlink-lib-18.ebuild 728 BLAKE2B 9d452fd9349f3454cc6f5c5958d9c09b910bf9d48c6a30391f9ba0662802064b9a941db005c007aaa0c0a3c2e8be786d5ae48a250610876bbe4cabaa405a0eeb SHA512 3350181f6b4bfb6ee4adde99dd576f014543b2d7649849ffd9df12954731f6f1718c0513c9ae3f983e07284d35d0fe55b27d58a58ca62fdd1b6bb65fe6334e87
+EBUILD unsymlink-lib-19.ebuild 728 BLAKE2B 2d2b3e5f369ab38f76fc1365da0997b206cbddaeb6f59f0c0422142112b95812e61ecc683ef0cb65db5c989a57f8c77ca49864ae2bd3ee5ae2ea722f1b8b8681 SHA512 5d6a758a2d33f2a713d18cf0db86f5341de88f633d4f2d3ec18ac132cb20417fa1523389354117d782e2eb69062fd40375e2ad0ff92416e3bf2a68dcb428d048
MISC metadata.xml 401 BLAKE2B f16ce51083f8054e7190c2d5fc193808898071af155cc8442a9ef7064cb4d46e6639d8724f85a4a0f551477c6f7ae0f81434c6bef8bd88b2077ea7b7e1f2133b SHA512 dbd79971b54d9027956c46586b547f8308404e273e91dd7ff84d3fbbd50936b8f19dd1dacde5e16a22ca2ef17924f19f66ec83e64c9f145f29322150db9e00a6
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-19.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-19.ebuild
new file mode 100644
index 000000000000..f7f1966a740b
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests are docker-based, you need a running docker daemon and you
+# should expect leftover images
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}