summaryrefslogtreecommitdiff
path: root/app-portage/unsymlink-lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /app-portage/unsymlink-lib
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'app-portage/unsymlink-lib')
-rw-r--r--app-portage/unsymlink-lib/Manifest2
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-20.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
index 188da97cf76f..fd6b9f8a3b9f 100644
--- a/app-portage/unsymlink-lib/Manifest
+++ b/app-portage/unsymlink-lib/Manifest
@@ -1,3 +1,5 @@
DIST unsymlink-lib-19.tar.gz 11235 BLAKE2B 955583517c485125722bdc808e1038c038509fad0afe0774f16299f2eb3a6088d7433e11565567bb3c9976a27910fbd9fe92289eaa210062f38eb9e3b15e120b SHA512 98943c887aeb70fc667c2092b985fe0078f127123d271cc45e1abb3e9b6218f1190bd23f140fa9775dca1d473d03113e6cfa8aeca8985cfc31f1cb459c4c620e
+DIST unsymlink-lib-20.tar.gz 11333 BLAKE2B bf5ab4390e52dceb0f86717abc21d752449754b6cb1083b34547997377c24618412d1dfef9736286d5af35632113885c998bddaeb373267280289b93a9ee8f40 SHA512 084d733046499ffa3bbeec6f59e72a8bd8bd9924c6f4cdca5f1bec5a6ef59502ceb19b156783c14d0418dbcd37025da65caaa2ce47665a26cec609e1895b01fb
EBUILD unsymlink-lib-19.ebuild 727 BLAKE2B 9f7fc0461042aa9ff844859a7043b57644d37e65943df81ba243fbf635b98c22d2051ba9a7b7698e02bb59fff638069a7eb604542f25ad0cbaa650aed04ad011 SHA512 e7984ba5b8c5b03817b59afea51792e124ab8b10d492a04b33954a0c69bed8dd56dcdca73afa216aac0e445b3a4d6edbab2576a758cec42b96c02c2828a91321
+EBUILD unsymlink-lib-20.ebuild 728 BLAKE2B 64c902e855cb5ef1d1297dccb882d0036493a82616f4e5181f5c6150dee6d092ad28fd3534c6babb6723327ac2bd1e23a043224e17dc308fae0f05e34a1a68c6 SHA512 5b7921d3c5325c15c029afdc222cafedf70cb268c252837ae73149a0acfeda2740e883e02b1335a14035418f952b4b5af37464e2644e93c9195220cb882d06cc
MISC metadata.xml 401 BLAKE2B f16ce51083f8054e7190c2d5fc193808898071af155cc8442a9ef7064cb4d46e6639d8724f85a4a0f551477c6f7ae0f81434c6bef8bd88b2077ea7b7e1f2133b SHA512 dbd79971b54d9027956c46586b547f8308404e273e91dd7ff84d3fbbd50936b8f19dd1dacde5e16a22ca2ef17924f19f66ec83e64c9f145f29322150db9e00a6
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-20.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-20.ebuild
new file mode 100644
index 000000000000..46e5fca98af7
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-20.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests are docker-based, you need a running docker daemon and you
+# should expect leftover images
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}