summaryrefslogtreecommitdiff
path: root/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-portage/unsymlink-lib/unsymlink-lib-16.ebuild')
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-16.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
new file mode 100644
index 000000000000..562293f6186a
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_test() {
+ # tests are docker-based
+ :
+}
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}