summaryrefslogtreecommitdiff
path: root/app-portage/unsandbox/unsandbox-1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/unsandbox/unsandbox-1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/unsandbox/unsandbox-1.ebuild')
-rw-r--r--app-portage/unsandbox/unsandbox-1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/unsandbox/unsandbox-1.ebuild b/app-portage/unsandbox/unsandbox-1.ebuild
new file mode 100644
index 000000000000..34a3551ad98a
--- /dev/null
+++ b/app-portage/unsandbox/unsandbox-1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="The Sandbox escapist tool"
+HOMEPAGE="https://dev.gentoo.org/~mgorny/dist/unsandbox.c"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/unsandbox.c"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/unsandbox.c "${WORKDIR}"/ || die
+}
+
+src_compile() {
+ tc-export CC
+ emake LDLIBS=-ldl unsandbox
+}
+
+src_install() {
+ dobin unsandbox
+}