summaryrefslogtreecommitdiff
path: root/app-portage/ufed/ufed-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/ufed/ufed-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/ufed/ufed-9999.ebuild')
-rw-r--r--app-portage/ufed/ufed-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/ufed/ufed-9999.ebuild b/app-portage/ufed/ufed-9999.ebuild
new file mode 100644
index 000000000000..5946596356fe
--- /dev/null
+++ b/app-portage/ufed/ufed-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib git-r3 autotools
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/ufed.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEPEND="sys-libs/ncurses:0="
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Change the version number to reflect the ebuild version
+ sed -i "s:,\[git\],:,\[9999-${EGIT_VERSION}\],:" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)/ufed
+}