summaryrefslogtreecommitdiff
path: root/app-portage/smart-live-rebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/smart-live-rebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/smart-live-rebuild')
-rw-r--r--app-portage/smart-live-rebuild/Manifest4
-rw-r--r--app-portage/smart-live-rebuild/metadata.xml22
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild34
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild32
4 files changed, 92 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
new file mode 100644
index 000000000000..42d495afec35
--- /dev/null
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -0,0 +1,4 @@
+DIST smart-live-rebuild-1.3.5.tar.bz2 16004 BLAKE2B fa1fcb13c739ef15b343de3460b029a311a4c08be3ec44ff5c0c89fef4d07fde7fa5558444b25ce234d64b03465b4a401593600f3fec5cbbfba76bdc76fcca34 SHA512 46933334c8c46a056c837e60a5d8aed30a35b1ddd20d7c0f03e813f6cac11cc2dc9469674b1e9c23d94c9ebc474e5eacc7aa0e8f82492554a7f49b438ed740d2
+EBUILD smart-live-rebuild-1.3.5.ebuild 828 BLAKE2B c41e1faaca3e824ef91b121fdf103bb2ba23646ac887fcaf7f41fc454683c586667d683767c2817d0b30dc70e56890769cdc53c2f42ac196da3160cca1ffcd0f SHA512 518cbbed81af2d38863bbd3c43ae4a3bb159234c17016f8c459a7eca77d937ccf68a9a4f7a0f80ff12ab43bb4c6d8cddf6a88b3f4f6b7dca1b43441fb2b75f34
+EBUILD smart-live-rebuild-9999.ebuild 736 BLAKE2B 0935bb883cd0f84a9a0fa634cd16ec0fc76f89176cec3c80bfef7425061bb5addb92c7a1bf1596c4a539db874a0d1adef18443cd54249353c6ae64702523b09d SHA512 84782417c0aa0fa96fd1638b6d25cb2bb22fa0b9ae82de28395cec71c58c818251d3310603e48c97cefce86d3822b48329a45d8cdb21c5bcc2137fe96ad40abf
+MISC metadata.xml 769 BLAKE2B 5aaad83253d55d1096c19aeb6a980e31456ca20a1ecfdb45e93dfd2f72cff7cce61124bf546932266d24d0c9fd0493ae4c61089ab291028360834c2f6d237e5a SHA512 d11c942868f0166c646922088dfecf3047f8ca017b85965382bec8fc794e11d6ffdea27a9156a41faec10a79a13836b13d8b9213a44e57672e1355fbd6bfd0da
diff --git a/app-portage/smart-live-rebuild/metadata.xml b/app-portage/smart-live-rebuild/metadata.xml
new file mode 100644
index 000000000000..fd31fc1dbcf4
--- /dev/null
+++ b/app-portage/smart-live-rebuild/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <longdescription>
+ A smart replacement for various live package rebuilding
+ solutions. smart-live-rebuild tries to update the source
+ checkouts of live packages and calls emerge to rebuild those
+ which are out-of-date.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://github.com/mgorny/smart-live-rebuild/issues/</bugs-to>
+ <remote-id type="github">mgorny/smart-live-rebuild</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
new file mode 100644
index 000000000000..31ec3b6360b7
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
new file mode 100644
index 000000000000..c8a7533d0933
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}