summaryrefslogtreecommitdiff
path: root/app-portage/repo-commit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /app-portage/repo-commit
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'app-portage/repo-commit')
-rw-r--r--app-portage/repo-commit/Manifest4
-rw-r--r--app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild24
-rw-r--r--app-portage/repo-commit/repo-commit-9999.ebuild32
3 files changed, 34 insertions, 26 deletions
diff --git a/app-portage/repo-commit/Manifest b/app-portage/repo-commit/Manifest
index bc11a0a1a84e..bc9e24dfb038 100644
--- a/app-portage/repo-commit/Manifest
+++ b/app-portage/repo-commit/Manifest
@@ -1,4 +1,4 @@
DIST repo-commit-0.4.1.tar.bz2 54416 BLAKE2B 85b4c9608baac4fc267047cb3177a80fa9d5ef761cb70a7d752acf5448607330c873ec1180c207a399e81b55d82ebf23816cfefed380ecb2de0d5eff3fc63b61 SHA512 25d4ec02605454e49dafb59a753abbe6b28b2e07225d5479bfa0e0d493d3dd6bd2302dd4efaa2d6a6af5f8c7e41a5029ac8edb9d7b1dd8ec9349a057d1d61622
-EBUILD repo-commit-0.4.1-r1.ebuild 406 BLAKE2B 4a2c24f551d4bef743442f4d06b4ad7d378126bd692b7e74fed8d74fab8e4d0672071f675ada1b8cfad5fcd58a716d3efa903e0ade97a3a62dcf826ff4f3b133 SHA512 0e67f6cd1198b0b534f3b6a92e43eb54e0a2ca19aed096d4b1fc28f67ce6afc7c95783426a2f072f4e184d73fb1c7252804c7680ae1573550519db07f0de86b7
-EBUILD repo-commit-9999.ebuild 555 BLAKE2B 850858bde43d1809839472bda73b74f958d634999ae828cd2517d4e414ee81d4f2c11342155fd0fc92797e9411c6d0e5af7d4adb663f1cd3b754baf8b2154ffa SHA512 fc7990cb9c61156cae3ae92c33f3d3ab76bae92269c9f595fad5685bcda0cd7ae34d853aa69baec498b9fff7d23c6daaa4025fa6552ea922f1dff1239d61ef8d
+EBUILD repo-commit-0.4.1-r1.ebuild 565 BLAKE2B 6b390d82724de16fabe776b92eb6c44d8a5eb9ff6e4ec5334b6597ed30542b0f4dfff17fda889c9a92f79ef34258f5c4d84e8cb717a5c638d4a1f0950711ad69 SHA512 5bfa2f49e4a3df33e412b9076b03bbcc691e8ad0d3c805a11ce1dc6b3a47d92d830a497ade2e108567eae4919224a99159e6249f500d951b25d2edbb574dfdc1
+EBUILD repo-commit-9999.ebuild 565 BLAKE2B 6b390d82724de16fabe776b92eb6c44d8a5eb9ff6e4ec5334b6597ed30542b0f4dfff17fda889c9a92f79ef34258f5c4d84e8cb717a5c638d4a1f0950711ad69 SHA512 5bfa2f49e4a3df33e412b9076b03bbcc691e8ad0d3c805a11ce1dc6b3a47d92d830a497ade2e108567eae4919224a99159e6249f500d951b25d2edbb574dfdc1
MISC metadata.xml 457 BLAKE2B adf49765568b3c6a4ad55eff2daf1f1a5025b26dff64aa1248355efc56ed62bdb4d6ff36d3340f2efb59d3cbd94294d6ce1d78a46aa6db0fe86ce0c3d556ec2e SHA512 5e0a666c83864d8c5701b47903b0554d21d19dd2f49c2831f4d22bf5edc469e84a0c16f024bd33490f937dc0d9a046118047b4d95cf2a972bea9bfb9b7349071
diff --git a/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild b/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild
index 978b47e224cf..5e2bdee57fc1 100644
--- a/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild
+++ b/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild
@@ -1,17 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://bitbucket.org/gentoo/repo-commit/"
-SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=">=sys-apps/portage-2.2.0_alpha86"
+RDEPEND="sys-apps/portage"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
diff --git a/app-portage/repo-commit/repo-commit-9999.ebuild b/app-portage/repo-commit/repo-commit-9999.ebuild
index 97ac51081e02..5e2bdee57fc1 100644
--- a/app-portage/repo-commit/repo-commit-9999.ebuild
+++ b/app-portage/repo-commit/repo-commit-9999.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
-EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+inherit out-of-source
-inherit git-r3
-#endif
-
-inherit autotools-utils
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://bitbucket.org/gentoo/repo-commit/"
-SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=">=sys-apps/portage-2.2.0_alpha86"
-#if LIVE
+RDEPEND="sys-apps/portage"
-KEYWORDS=
-SRC_URI=
-#endif
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}