summaryrefslogtreecommitdiff
path: root/app-portage/repo-commit/repo-commit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /app-portage/repo-commit/repo-commit-9999.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'app-portage/repo-commit/repo-commit-9999.ebuild')
-rw-r--r--app-portage/repo-commit/repo-commit-9999.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-portage/repo-commit/repo-commit-9999.ebuild b/app-portage/repo-commit/repo-commit-9999.ebuild
index 97ac51081e02..5e2bdee57fc1 100644
--- a/app-portage/repo-commit/repo-commit-9999.ebuild
+++ b/app-portage/repo-commit/repo-commit-9999.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
-EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+inherit out-of-source
-inherit git-r3
-#endif
-
-inherit autotools-utils
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://bitbucket.org/gentoo/repo-commit/"
-SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=">=sys-apps/portage-2.2.0_alpha86"
-#if LIVE
+RDEPEND="sys-apps/portage"
-KEYWORDS=
-SRC_URI=
-#endif
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}