summaryrefslogtreecommitdiff
path: root/app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
commit57c2e006d0af9ab77ced676461d7100cade4a716 (patch)
treefedd61a96505af97dea0e78425b1b7a70b813a46 /app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild
parent664924d8659185e3b43f99ee8a0b88177efb93dc (diff)
gentoo auto-resync : 23:11:2022 - 01:07:24
Diffstat (limited to 'app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild')
-rw-r--r--app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild b/app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild
new file mode 100644
index 000000000000..ddee9ac385b4
--- /dev/null
+++ b/app-portage/pycargoebuild/pycargoebuild-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator for Rust/Cargo ebuilds written in Python"
+HOMEPAGE="
+ https://github.com/projg2/pycargoebuild/
+ https://pypi.org/project/pycargoebuild/
+"
+SRC_URI="
+ https://github.com/projg2/pycargoebuild/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest