summaryrefslogtreecommitdiff
path: root/app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-13 18:49:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-13 18:49:18 +0000
commitf8d671851faf1ca201cec0490ead4642c8987bae (patch)
treeb8fa88a5eb1312b7f587c4670cf04cb4003e7714 /app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild
parent7c1ac01728d0156998ee45be74f80b378d96c31d (diff)
gentoo auto-resync : 13:11:2022 - 18:49:18
Diffstat (limited to 'app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild')
-rw-r--r--app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild b/app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild
new file mode 100644
index 000000000000..ddee9ac385b4
--- /dev/null
+++ b/app-portage/pycargoebuild/pycargoebuild-0.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator for Rust/Cargo ebuilds written in Python"
+HOMEPAGE="
+ https://github.com/projg2/pycargoebuild/
+ https://pypi.org/project/pycargoebuild/
+"
+SRC_URI="
+ https://github.com/projg2/pycargoebuild/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest